Home Screen Spinning Wheel

(Copied this from the previous forums)

When I open the app, occasionally I’m greeted with a spinning wheel in the top left of the home screen that doesn’t go away for about ten seconds. When it is there, I can’t do anything in the app. Once it goes away, I can. If I go back to the home screen again, the wheel returns for another ten seconds. This happens every time I go home. If I restart the app, it usually goes away, but this is incredibly frustrating as you shouldn’t have to continually restart an app to get it to work.

Anyone else run into this?

Have tried all the usual steps of uninstalling, clearing cache, restarting, making sure I have the latest version of the game and my OS, etc. This issue has been going on for many months now for me. I’m running a Pixel 8 Pro.

From support user:
Hey @Tender82! I appreciate you trying out the troubleshooting steps. Please ensure that you are connected to a stable internet connection and that no other apps are running in the background. If the issue persists, please contact us via in-app support for further assistance.

Tender82:
Thanks for the reply!

Internet connection is stable. I’m not sure having no other apps running in the background is a valid request, if I’m being honest. I use my phone all day for many things including other Niantic games, specifically Pokemon Go. This issue does seem to happen even when I haven’t opened that other app.

I’ve contacted support in the app and didn’t really get anywhere unfortunately. They had me to the basic troubleshooting steps but weren’t helpful otherwise.

Any other suggestions? This is an incredibly frustrating bug that’s been happening for a long time.

NianticSupportSC:
Hi @Tender82! This issue might happen if there are some connectivity issues. Please ensure you have a strong internet connection, either via cellular or Wi-Fi. However, please be aware that a strong Wi-Fi signal or cellular data (i.e. having full bars) isn’t always sufficient to guarantee a stable connection. Trying a ping test online can help you determine which connection is more stable.

You can also try checking in another compatible device and see if it gets resolved. We’re constantly looking for ways to improve, we’ll be sure to share your feedback with my team.

Tender82:
Thanks. It happens so frequently and I know I have a great connection in my house. I’ve tried with both Wi-Fi and cellular data. I even have a new Wi-Fi router at my house now and the same thing happens. It happens everywhere and not just here.

I’m using a Pixel 8 Pro and I’m not sure why such a new phone would have issues.

Any other suggestions? Thanks!

GeqRdEeyT8qm:
Hey @Tender82! We are sorry to hear that the problem is still ongoing. Please ensure that the date and time settings on your device are automatic. If the time is significantly out of sync with the current time, Pikmin Bloom will not launch. Also, have you considered logging into your account from another device? In this way, we can identify whether the issue is with the device.

Tender82:
Time is synced and automatic.

I use this phone as my daily driver and only have a Pixel 4 XL as a backup. I could try it on there.

I don’t remember this on my 6 Pro, but I just transferred the settings. I’m not sure why a newer phone would have this issue.

Tender82:
Turns out it was the 2XL.

I don’t see the problem there, but I’m also not using it as my normal phone.

Is there a way to get or see logs on my 8 Pro when this happens? Perhaps we can narrow down what the actual issue is? I’m guessing that it’s related to something on my phone but I have no idea what it could be related to.

I also occasionally have issues opening Pokemon Go. It stops loading about 3/4 of the way. Could these two be related?

NianticSupportG:
Hey @Tender82! Please ensure that your Google Play Store is updated to the latest version. If not, please update it and then try rebooting your device. Additionally, check your device’s Play Protect status.

Once done, try uninstalling and reinstalling your Pikmin Bloom app from the Google Play Store to see if that resolves the issue.

New update from me on 9 April:
No luck trying that. Everything is up to date and the reinstall didn’t change anything.

I did notice something though on my run yesterday. If my app is in spinning wheel on home screen mode, the app doesn’t count my steps at all. I restarted and my steps updated. Could that be related to the issue?

1 Like

Hi @Tender82! We welcome you to the community forum.

We have created a support ticket for this issue. Please reply to the email with a screen recording so we can investigate further.

Got it! When it happens today, I’ll grab a screen recording and send it over.

Thanks so much for opening a support ticket. This issue has been so incredibly frustrating. Hopefully we can get it sorted out soon!

I often get the spinning busy indicator the first time I open the app outside of my house in the morning. I have to kill the app using the android square button on the bottom and relaunch. After I relaunch the app stops hanging and is back to normal.

I feel it is a connection issue too. I usually don’t encounter this problem during the rest of the day, just on first launch outside, maybe when I’m transitioning from my indoor wifi to cellular.

I am getting the home screen busy icon again without leaving my wifi. Haven’t used the app for a while and when I opened it just now, the issue started occurring. Each time I navigate to the home page in spins for 5-7 secs. Ex. check petals or pikmin or map, etc. when returning to home screen get the spinner. Did not encounter the issue at all earlier today, even when leaving my wifi coverage and switching to cellular.

Again, after restarting the app, the problem went away. It’s like on app starting up it grabs a bad connection and doesn’t release.

Not noticing any connection problems with my wifi. Have been using my desktop without any noticable connection issues

Hope this helps.

KippyPippy, maybe we can figure out what our setups have in common.

Do you have or use any of the following:

  • Google Fit
  • Google Watch
  • PokemonGo

And what phone do you current use?

Thanks for the help in narrowing this down further.

Hi, I had the exact same problem after v92 update on my Pixel 5.

I went in the settings of the phone, cleared cache and storage data (or user data, whatever it’s called in English) for the Pikmin Bloom app (I had more than 1Gb used), relaunched the app and now the issue is gone, no more spinning wheel at every return to home !

I think if you just reinstall the app it keeps old user data, clearing cache isn’t sufficient but clearing storage data is the key here imho.

Note that when you clear storage data you will have to login again, go through first launch and set up the app as if it was the first time.

Hope this helps.